Lync Server 2010 Setup or Remove Lync Components fails on Windows Server 2008 R2 SP1

If you get this error during installation of Lync 2010 on a 2008 R2 SP1 server,

Name of prerequisite: Wmf2008R2   MM/DD/YYYY HH:MM:SS AM
Name of prerequisite: Wmf2008R2   MM/DD/YYYY HH:MM:SS AM
Type of prerequisite: exe   MM/DD/YYYY HH:MM:SS AM
Method used to check prerequisite state: WmfNeeded2008R2()   MM/DD/YYYY HH:MM:SS AM
Result of state check: True   MM/DD/YYYY HH:MM:SS AM
Executing external command: C:\Windows\system32\dism.exe /online /norestart /add-package
/packagepath:C:\Windows\servicing\Packages\Microsoft-Windows-Media-Format-
Package~31bf3856ad364e35~amd64~~6.1.7600.16385.mum /ignorecheck   MM/DD/YYYY HH:MM:SS AM
Installation result: -2146762496   MM/DD/YYYY HH:MM:SS AM
Error: Prerequisite installation failed: Wmf2008R2
Details
Type: PrereqInstallFailed
Stack Trace
at Microsoft.Rtc.Internal.Tools.Bootstrapper.BootstrapperTask.AddMsiPrereq(String prereqName)
at Microsoft.Rtc.Management.Internal.Utilities.LogWriter.InvokeAndLog[T](Action`1 action, T arg)
Type of prerequisite: exe   MM/DD/YYYY HH:MM:SS AM
Method used to check prerequisite state: WmfNeeded2008R2()   MM/DD/YYYY HH:MM:SS AM
Result of state check: True   MM/DD/YYYY HH:MM:SS AM
Executing external command: C:\Windows\system32\dism.exe /online /norestart /add-package
/packagepath:C:\Windows\servicing\Packages\Microsoft-Windows-Media-Format-
Package~31bf3856ad364e35~amd64~~6.1.7600.16385.mum /ignorecheck   MM/DD/YYYY HH:MM:SS AM
Installation result: -2146762496   MM/DD/YYYY HH:MM:SS AM
Error: Prerequisite installation failed: Wmf2008R2
Details
Type: PrereqInstallFailed
Stack Trace
at Microsoft.Rtc.Internal.Tools.Bootstrapper.BootstrapperTask.AddMsiPrereq(String prereqName)
at Microsoft.Rtc.Management.Internal.Utilities.LogWriter.InvokeAndLog[T](Action`1 action, T arg)

the reason for this is because Lync Server installation prerequisite check cannot locate the  Server 2008 R2 SP1 version of Microsoft Windows Media Format.

So as a workaround for this issue you need to install Windows Desktop Experience.🙂